To eko:

Exactly what do you mean by docking?

Are you moving the dialog?

Are you moving a control on the dialog?

Is this docking thing when you lift the left
mouse button up?

Ewayne
Posted on 2002-02-11 14:19:48 by Ewayne
docking when i move the dialog to the border
Posted on 2002-02-11 14:29:24 by eko
Hi eko

Here is the source for the test app. Open the projects .txt file and read the short instruction. Have fun. :grin:

KetilO
Posted on 2002-02-11 14:46:41 by KetilO
To eko:

Thats not a bug, it's just moving the dialog back
within the boundries of the work window.

Ewayne
Posted on 2002-02-11 14:47:32 by Ewayne
Ewayne : i ididnt know ,., sorry ;)
anyway i still have problem with the rectangles



KetilO :
in this verstion it seems to be all good except
the move on the toolbox and on the output .
becuase it moves well on all the other windows except the output and the tool box . i checked what are the diffrents between them .
i notice that you add WS_CLIPSIBLINGS in the project and in the creation of the dialog editor window
i add WS_CLIPSIBLINGS in the create of the output(Do_OutPutTool) and this fixed the problem
about the tool box i didnt succeed to fix the paint problem



in picture you can c the paint problem . this only happens ( now ) on the toolbox window

bye
thanks

eko
Posted on 2002-02-11 15:44:54 by eko
Hi eko

So WS_CLIPCHILDREN was the problem. About the toolbox. The toolbox has a static as it's parent for the buttons. I guess you only needs to set the style for it. The properties window also has a static as its parent and seem to work well.

Thanks eko

KetilO
Posted on 2002-02-11 16:22:17 by KetilO
I dont get anymore white bloches or anything else..

It works like it should. I think you solved the problem on my machine atleast Ewayne :)

Torch
Posted on 2002-02-11 17:14:23 by Torch
To Torch:

Thanks Torch, now I just need to get the black
rectangles back for eko.

Ewayne
Posted on 2002-02-11 18:23:10 by Ewayne
To eko only:

We'll just pick on moving a control first, see
if the black rectangles are back and the painting
is still ok.

Thanks,

Ewayne
Posted on 2002-02-11 19:17:48 by Ewayne
the problem is still there
Posted on 2002-02-12 09:07:31 by eko
To eko and Torch:

Torch I know the last update you tried works ok on
your machine, but I don't like what I had to do to
make it work.

I think I found some of the problems, when I made
some changes to ResEdit so it would work as an
interface to AsmEdit and stand alone I removed
some of the WS_CLIPCHILDREN and WS_CLIPSIBLINGS
styles, because when ResEdit is used in AsmEdit
it's no longer the parent window, it's just another
child window.

I've added the WS_CLIPCHILDREN and WS_CLIPSIBLINGS
styles back in.

See if this works.

If not I would like to take this problem offline
and work with both of you via email, so I don't
tie up the message board.

Let me know.

Thanks,

Ewayne
Posted on 2002-02-12 09:37:47 by Ewayne
in this last version i dont see the rectangles
Posted on 2002-02-13 05:40:56 by eko
To eko:

Give me your email address and I'll work with you
offline, I'm going back to my original code of
using DC's and drawing frames, etc. I should have
left the code the way it was when I first wrote
the program. Then it should be compatible with all
platforms.

Thanks,

Ewayne
Posted on 2002-02-13 06:11:16 by Ewayne
Hi Ewayne

This thread is very long and contains a lot of zip's. Do you want me to delete all zip's to save board storage space?

KetilO
Posted on 2002-02-13 08:26:49 by KetilO
Hi KetilO,

I would just as soon delete the complete thread.

It got out of hand.

But maybe you should leave your last post and
this post so folks will know whats going on.

I think i'm getting my program so it will work on
all platforms.

When I get it done I will start a new thread.

Thanks,

Ewayne
Posted on 2002-02-13 08:40:52 by Ewayne