I just installed XP and I'm wondering.. somehow I can't compile any programs.. I just get that stupid error messagebox saying that ml.exe did something wrong.. same with link.exe etc..

Anyone had that before? What's the way out of this disaster?

Thanks in advance,
Posted on 2002-02-28 19:26:45 by JimmyClif
I had to manually set the enviroment variables then reboot.
(Which I thought was funny since XP is supposed to reduce the number of reboots.)

Manually set the path in My Computer->Properties->Advanced->Enviroment Variables.
(I set them for "All Users", not just me.)

Hope that helps.

Posted on 2002-03-01 10:26:17 by bigRahn

I had to manually set the enviroment variables then reboot.

on 2k/xp when you run default explorer.exe shell, closing cmd.exe
and launching it again is usually enough for a newly added env. variable
to be available in the shell. If you run a custom gui like geOshell,
however, it seem the env. variables are not updated the same way,
and you may have to "recycle" the GUI (which will definitely be faster
than rebooting ;).
Posted on 2002-03-01 10:48:19 by f0dder
Thanks... I see where this is going... Can someone "sissy-guide" me thru this please :tongue: ?

Posted on 2002-03-01 13:47:38 by JimmyClif
I'm just curious, what version of XP are you running.

Although I doubt it, the different ones may act differently.
My previous post about manually setting the enviroment variables was based on Advanced server. I haven't put it on my Professional box yet.
Posted on 2002-03-01 17:59:37 by bigRahn
I didn't know there was an XP Advanced Server?
Isn't there just Home/Professional?
Posted on 2002-03-01 18:07:12 by bitRAKE
I'm using the Professional edition... Well, I got where you sent me and there are two boxes... Top one is for my variables, bottom ones are system variables.. but by all means what do I have to write in there? It's not like it's DOS where all I have to do is write Path=c:\masm32;c:\masm32\bin\ :)

Doh.. I feel I'm getting old :(
Posted on 2002-03-01 18:18:51 by JimmyClif

Maybe I missed something important in your posts, but I don't know what exactly is the problem.

I am running Windows XP Pro on my Computer I have just copied my MASM32 Folder back to HD and there is no problem at all running it.

YaWNS aka Stefan K.
Posted on 2002-03-01 18:19:09 by YaWNS
i dont recall what operating system you were using prior to xp but if you were using windows 98 then i know what maybe your problem.

your probably running into that problem where the spaces in your path arent being recognized.

also if you post the specific error your getting that will help.
Posted on 2002-03-01 19:42:55 by smurf
I'm kinda winging this since I'm on a different computer. (Actually, I'm installing on XP pro as I type this, so I should be pretty accurate for you :))

So you're at the env. variables screen.
In the "All Users", go to "Path"
Edit this value by adding ";c:\masm32;c:\masm32\bin" to the end of it.
(Note the semicolons, used to seperate the different values in the list.
Since I had no prior development enviroment on this machine, I add two new variables:
LIB = c:\masm32\lib
INCLUDE = c:\masm32\include

(If you already have these 2 variables, then just add the path.)
And that should do it.
Open a command window (start->run->cmd), type "ML" and hopefully you'll see the information.

Hope this does it for you...since I don't know anything about assembly language at this point, at least I can help with this.

(Oh, the wife yelled at me...Guess I wasn't supposed to mention advanced server, since it's not released yet. But when you use it on every computer, everyday, you take these things for granted. Guess I'll go change my location now to say "The evil empire, redmond, wa" :) Now I'll try to never mention it again.)
Posted on 2002-03-01 21:41:13 by bigRahn
thanks for the contributions but still no difference :(

Here I attach the little messagebox I get whenever I run ml.exe
Weird thing is .. that now I even receive an nice changing error whenever I rightclick on MyComputer and select properties...
Sometimes it's an dll which is missing, sometimes it's rundll.exe which does an error...

- I think I just format my drive and reinstall XP...
Posted on 2002-03-01 21:57:35 by JimmyClif
I'm re-installing atm... Nice to see that some things never change with new Windows Versions *grin*
Posted on 2002-03-01 22:06:29 by JimmyClif
Hey, I just finished installing it anew and weird enough - It works!
I didn't even fiddle around with the Environment variables...

I guess my stepson accidently did something bad to former installation... [ I already locked him into the basement :grin: ]

Well, thanks anyways && sorry for the trouble and work I gave everyone... Especially bigRahn who is installing XP Pro just because of me... (sorry dude)

Well, now I can try to figure out why my little app works fine on Win98SE and on WinME but refuses to do it's services on XP...

BTW: I guess I'm the quickest "XP cuteness remover" around now... I can cut off all the junk in less than 3 approx. minutes.

Thanks again,
Posted on 2002-03-01 22:58:33 by JimmyClif
Wow! Love to have people think I was putting a lot of work into installing XP and all...
but actually, already had it set up on a machine. I just added MASM.
(Well, okay. I had to walk in the other room, then clear all the junk away from the keyboard. But I would have done that anyways.)

Anyhow, if anyone has anymore XP questions, I'll be happy to help.
Posted on 2002-03-01 23:31:08 by bigRahn
Uff, that makes me feel a lot better...

If you are already suggesting XP questions :D and while I'm at it:

* How do I turn of that %$#$ AutoPlay feature for my 2 drives ?
(without using TweakXP)

Thanks a lot ;)
Posted on 2002-03-02 00:27:42 by JimmyClif
really good site for registry questions is www.regedit.com

Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CDRom]

Value Name: Autorun
Data Type: REG_DWORD (DWORD Value)
Value Data: (0=disable, 1=enable)
Posted on 2002-03-02 10:03:38 by smurf
Nothing wrong with changing a key in the registry, you can also right click on the drive, choose properties, and there is an autoplay tab.

(Sure wish previous editions had this)
Posted on 2002-03-02 14:48:35 by bigRahn
I knew about that right-click Properties thingy, but choosing for 8
different things (music, files, video etc) everytime to take no
action.. is

A) annoying
B) doesn't really work as it still examins what's in the drive before
looking up what to do with it. This takes time if you have a CD
with a couple thousand files...

All I want was something like a checkbox saying
[] Check here if you want the AutoPlay feature disabled forever

Maybe I expect too much again ;)

Thanks tho.

Posted on 2002-03-02 15:12:20 by JimmyClif
Okey Dokey.
Rename this file to a .reg (the web page doesn't let me upload the type.)

To turn autoplay off, edit this in notepad and make the 1 into a 0.
(Or vice-versa to switch back.)
Then double click it.(Easier than using regedit :))

Drop it on to you shortcut bar, and you'll be set.

(This could be a fancy script to automaticaly change it to the opposite of what it is...but that's for another day.)

Have a good weekend. I'm off to play video games!

Rahn :)

(Thanks Smurf, for pointing out where the key was.)
Posted on 2002-03-02 19:04:45 by bigRahn
Have a good one ;)
Posted on 2002-03-02 19:09:44 by JimmyClif