Someone once posted a fix in the registry to get Quick Editor to open files assosciated with it, so I can double click a .asm file in explorer and have QE open it.

Does anyone remember this setting? I need it to set up MASM32 on another machine.


TIA
Posted on 2002-02-28 21:22:02 by Ernie
Old version's QEditor has some bug at this...

search registry, then you could find like this

C:\masm32\QEDITOR.EXE "%1"

this is right, but old version might below

"C:\masm32\QEDITOR.EXE "%1""

So, Edit your registry yourself...
Posted on 2002-03-01 19:42:00 by muzidowa
muzidowa,

Thanks for publishing these results, qeditor.exe does not write to the registry at all and depending on how the particular machine is set up, it sometimes has the wrong information passed to it by Explorer. It will handle quoted file names, unquoted file names and the variations of Winfile.exe, WinExec, CreateProcess, CMD.EXE and Command.com but it has no way of dealing with the registry as registry dependence is not within its original design criteria.

Regards and Thanks.

hutch@movsd.com
Posted on 2002-03-01 20:29:54 by hutch--
ernie: cant you just right click on an .asm and file and select open with/ choose program/ browse for the qeditor.exe and select always use this program to open this kind of file.
Posted on 2002-03-11 00:44:09 by smurf
Shift / Right click almost guaranties that the
"Open with ..." context comes up. Then browse for
your editor of choice, and select "Always use this
program to open this type of file"

farrier
Posted on 2002-03-11 03:44:00 by farrier
smurf and farrier,

Of course I know that. It makes a bad association on some systems (mine included), so it opens QE but can't load the file.

There are many times double clicking a file to open it in QE is just the best choice.
Posted on 2002-03-11 20:14:49 by Ernie