Here it is the first preview of my OS's GUI :)

With alpha blended windows of course, child windows and stuff

Ring0 code take care and read the instructions.asm file before using.

Its an pre-OS so boot it from a floppy :)

it is written in 32bitASM (TASM)
it is all about Windows,
but is NOT the Ms Windows

Any comments/oppinions ideeas for improvement will be appreciated

source code is NOT included yet...
but i might release it later
Posted on 2002-03-06 16:51:23 by BogdanOntanu
downloaded - written to disk - booted.

After booting comes this text:

Vesa X.X detected

then the systems keeps hanging in text mode.
If I press <Key 3> the screen starts flickering black and blue.

I'm using a ATI XPert 98, featuring a RAGE LT PRO AGP 2X chip.
Posted on 2002-03-08 09:49:52 by beaster
i get exactly the same senerio beaster. but i figured it was because i have a usb mouse though. *shrug*
Posted on 2002-03-08 14:02:07 by smurf

You should first press key G ( = go gfx) and ONLY then key 3 (= ps2 mouse setup)

but you can press key 3 multiple times :)


IF your card does not support VESA mode 114h (ie 800x600x65536 colors) you can try pressing key J instead, it will try an setup a 32768 colors mode (5:5:5 pixelformat VESA mode 113h) but i guess alpha blending routines will not work ok anymore then...

i can repair that if needed for some older ATI boards but i fast designed the code for 65535 colors first.

Text mode is not working anymore is just a leftover from early versions so you should allways press G or J to get into gfx mode.

It is working ONLY with PS/2 Mouse and AT keyboard because
there is no driver for Serial Mouse or USB Mouse keyboard,

Still you should be able to create a few windows in center of the screen, using keyboard, but you will not be able to move them if mouse driver is not working :(
(i guess i should make an arrows mouse simulator...).

Serial mouse driver will be ready soon but I have no hardware info about making OS drivers for USB devices yet ... sorry

Anybody else tested it?

Posted on 2002-03-08 15:51:11 by BogdanOntanu
Hi Bogdan,

I tried to test your OS but I don't get past the startup screen.

All I get is

>Loading SOL OS Ver. 0.0.4
>Setup Code Loaded Ok! :)
Setup Code Started

VESA X.X Detected
_ <- Cursor stays there!

After I press G my computer simply reboots, nothing else.

I am using a P150 with a standart Graphics card (with 2MB, remember? :grin: ) and I am using a PS2 Mouse, anything else important?

Greets YaWNS aka Stefan K.

Edit: No matter what key I press, it just reboots :(
Posted on 2002-03-08 16:18:48 by YaWNS
So many Hardware problems and this is just the beginning... and when i think i works on all of my office PC's :(

(but you always hear that from programmers dont you? :P )

Yawns, i forgot to mention that it requires a VESA 2.0 compatible video card, 2M of video ram should be ok because 800x600x65535 colors only takes about 1M of video RAM...

The 00000000 is your problem!

that is the address of the Linear Frame Buffer and I guess your video card has none....please excuse but i do not check for errors... i just assumed a least VESA 2.0 interfaces... i was doing this demo for Ville to see and then also posted it here... i must polish up the code a lot :( esp on error checking
Posted on 2002-03-08 16:44:17 by BogdanOntanu
There are some modern cards that dont support vesa.
Posted on 2002-03-08 17:18:23 by dxantos
Are they?

i whould like to know of any modern video card that does not support VESA ....

3dfx, ATI,NVIDIA,S3,and many old boards do support it... who else?

besides i can always switch this demo to DirectX (and indeed it can be helpfull for full screen DX applications) all i need is a pointer to video memory or backbuffer and some RAM for my window buffers ;)

i am not saying that VESA is the ultimate way to go, after all i should make drivers for all the video boards out there :( , but for testing and software rendering VESA is handy :)
Posted on 2002-03-08 17:30:22 by BogdanOntanu

I must be doing something wrong, it works PERFECTLY for me on my AMD 550 with an s3 video card in it.

Windows are created properly, alphablending works fine, mouse move is OK, esc reboots it all etc ...

Compliments on the good work here.

Posted on 2002-03-08 18:22:05 by hutch--
Worked great for me also :)


Can't wait to see the source :)

I did run into a problem with the "1" key...

I guess when you say don't press it maybe I should have listened....
Posted on 2002-03-09 02:16:39 by Sliver

I tested the OS on another computer here around me, and it works.
One time I freezed it, but I have not been able, to do it another time, so I can't tell ya, what I did :(

I didn't get it to crash completely (and let me tell you, I crashed every Windows I have seen, and I even crashed LINUX :) )

One thing I noticed (which looks a bit ugly, is the mouse cursor. Move it just to one border and the rest of the cursor gets warped to the opposing site. Otherwise it looks really great.

Good work man.

YaWNS aka Stefan K.
Posted on 2002-03-09 07:34:46 by YaWNS
G-3 combo worked fine for me... sure as hell beats my OS startup right now... example of it...


Status: In Development...

That is the logical (partition) bootsector for DynatOS right now... I've been concentrating more on a solid kernel foundation rather then jumping right to the GUI part of it. Any demos (none yet) can be found at the link below... the link might be dead for a couple of days yet since I changed the DNS entry for it.
Posted on 2002-03-09 07:56:06 by SpooK
to Hutch:
Thx man comming from you compliments are even bigger :). I whould like to know your oppinion about releasing sourcecode ... :stupid:

to YaWNS,
Yes i have no clipper yet, this is one of my main problems.

Breaking this demo should be easy :tongue: because it all runs in Ring0 so one crash will kill all OS, changing it to a Ring0/ring3 combo is another of my problems

to Sliver:
Thx so it works on NVIDIA also :)

to Spook
Maybe we can help eachother and generate to Federation's next OS to boldly go beyond MS Frontier sometimes in the far future :)


Dirty rectangles are also needed, but i am suprised to see how fast it works even without them... doh today computers are faster :alright:
Posted on 2002-03-09 08:47:33 by BogdanOntanu
ahh, works fine now!

I just missed to press "G" (maybe I didnt read the not so intensive - shame on me)
Posted on 2002-03-09 10:52:24 by beaster
(before pressing "G")
Posted on 2002-03-09 11:06:43 by bazik
After pressing "G" (looks a bit like Windows sometimes does :grin: )
Posted on 2002-03-09 11:07:41 by bazik

Are they?

i whould like to know of any modern video card that does not support VESA ....

It's not really an issue of not supporting VESA, it's lack of support for LFB (Linear Frame Buffer).

LFB is still a secondary method of accessing video RAM, after page swapping in the old A000/B000 segment. VESA will tell you if the card supports LFB.
Posted on 2002-03-09 12:57:03 by The Worrier King
Some video cards don't have VESA built into the video ROM, but most of these that I've seen do offer a "TSR" extension that supports VESA. :)
Posted on 2002-03-09 18:24:49 by S/390

Some video cards don't have VESA built into the video ROM, but most of these that I've seen do offer a "TSR" extension that supports VESA. :)
Hi S/390. At worst I've seen some old and cheap S3 and Matrox cards which had VESA 1.2 in ROM, and 2.0 as a TSR. What cards have you seen with zero VESA ROM support?

Posted on 2002-03-09 18:42:36 by Maverick
to Bazik:

Sorry man i do not think it will run on VMWARE :(

because it requires VESA 2.0 (yeah LFB) your "before pressing G" screenshot shows a LFB=0000000, video pitch=0000, pixel format=0:0:0 (ie R:G:B) so i guess my OS can not run under such circumstances (not graphically at least)

the second screen is what is left from my old text mode testing... you get that IF you press other key than G OR IF the VESA SetupVideoMode routine failed (your case IMHO)

Anyway the text screen will be removed in the next releases... it was not supposed to be there anyway...its just a leftover....hehe now that you show it "on screen" it really looks like a "blue screen of death" :tongue:

I do not have VMware, neither i know how to detect it and/or convince it to offer me some decent VESA 2.0 emulation .... could be usefull for me taking screenshoots from my OS and/or speeding up boot up process (now i use another PC to boot the floppy for testing)

to Beaster
nice to hear it works ok for you now... readme file was named "instructions.asm" :)

You see pal that i will have to write drivers for all video boards pretty soon (when my OS will need hardware acceleration) so i guess i will have to "study" DX drivers ... but curently VESA 2.0 will do because IMHO most modern cards have it.
Posted on 2002-03-09 19:21:13 by BogdanOntanu