hiya

Can anyone tell me how to use the option of RESOURCE COMPILER in MASM v7
Also im new to assembly language
i have tried all possibilities but it gives an error:

Microsoft Resource Compiler Version 5.0.0.1823.1 - Buil 1893
Using codepage 1252 as default
Creating rsrc.res

RC: RCPP -CP 1252 -f D:\~WIN32Asm\RCa98003 -g D:\~Win32Asm\RDa98003 -DRC_INVOKED -D_WIN32 -pc \:/
-E -I. -I. -I d:\hla\include


RC: fatal error RC1110:could not open rsrc.rc


Microsoft Resource to Object converter version 5.00.1736.1

CVTRES :fatal error CVT1101: cannot open rsrc.res for reading



i have tried to change the settings in Bres.bat file too but nothing seems to work.I have changed settings in Quick Editor too.

I want to use BORLAND'S Resourse Compiler instead of Microsoft Resource Compiler.

other functions works perfectly, i have compile a programs and it runs. :alright:

But i cant figure out how to deal with resource compiler.

Can anyone guide me here as to how to configure the resource compiler and the resource to object converter to go with Borlands Resource Compiler.

THanx in advance
Posted on 2002-04-18 11:09:01 by Ajnabi
it's looking for the file "rsrc.rc"
You obviously don't have the file named that...
if you change the name of your resource file it should work...

inotherwords,
your file name might be "blah.rc" change it to "rsrc.rc"

Sliver
Posted on 2002-04-18 12:43:46 by Sliver
If you want to use a resource file without having to resort to rsrc.rc just compile it using the command line:

\masm32\bin\rc ResourceFilename.rc

During the linking process just include the .res file like this:

\masm32\bin\link /SUBSYSTEM:WINDOWS filename.obj ResourceFilename.res

:)
Posted on 2002-04-18 21:38:36 by stryker
I think the clicking of build all in qeditor will default to rsrc.rc. if you name you rc file rsrc.rc, then it will compile.

other than that you have to do the compiling stuff in your own batch, i think.
Posted on 2002-05-13 16:56:23 by Ronin Magus