I finally vanquished Icz tut 10, or at least got it to work. That's the most discussed Tut on this board! There's nothing but a smudge on the screen where my search button used to be! :tongue:

I still have a pretty basic newbie question about compiling resources. Is there a way to make

#include "Resource.h"

in my rsrc.rc file work without actually copying the Resource.h file into every project folder? I tried every permutation I could find searching the board and in the Resource Compiler reference from Hutch's package (and some I just made up!) with quote marks, <>, \, full path names, specifying drive C or not, and I always got the same error message:

Rsrc.rc(4): fatal error RC 1015 : cannot open include file 'resource.h'

or whatever 'path\filename' attempt I was making. This occured with both QEdit and AsmEdit.

The experienced guys here sure take a lot of time answering newbie questions, and I appreciate it! Thanks!
Posted on 2002-05-22 13:27:35 by Bighillwill
hehe, just add this line in your rc file:

#include <\MASM32\INCLUDE\RESOURCE.H>
or
#include "\masm32\include\resource.h"


But be sure that the file is in the masm32\include folder, or specify yours.
Well this work if your project is on the same HDD (rather same letter). In fact, I've never had the other case (I mean on another HDD). I will try if you want then I'll say, or maybe on this forum have already tried...


Regards,
Thomas
Posted on 2002-05-22 14:28:14 by Vom-bonjour:-()
#include <resource.h> in the resource file. Make sure resource.h
is in your \masm32\include folder. Then, edit autoexec.bat (9x)
or set up environment variables (NT):

include=x:\masm32\include
lib=x:\masm32\lib

... and you can finally get rid of those pesky absolute paths everywhere.
Posted on 2002-05-22 15:32:33 by f0dder
Hi guys, thanks! You have solved my problem!

hehe, just add this line in your rc file:

#include <\MASM32\INCLUDE\RESOURCE.H>
or
#include "\masm32\include\resource.h"

hehe, Vom-bonjour yourself, Thomas! :grin: I did try that line in my .rc file! I tried both versions. Except for the all important initial \ . As:

#include "Posted on 2002-05-22 22:34:10 by Bighillwill