Hello all you friendly forum people!

I'm trying to learn to use a little mmx.. with masm-compiler.

I've tried entering some mmx-opcodes but the compiler tells me it doesn't recognise the regnames mm0 mm1 etc...I guess I haven't done the right preparations...

I tried this in the header

.586
.mmx

---
I wonder if someone knows of a source-code I can download or view on the net, which use mmx ( and compile under masm ), so that I can study it.

Or give me some hint here in the forum...

thanks!!

:)
Posted on 2002-05-23 18:54:16 by david
.586
.MMX

mov MM0, qword ptr
Posted on 2002-05-23 18:55:36 by bdjames
YES! It works now!
I didn't know about the capital letters!!!

GREAT ! THANKS BD!!!! :) :) :)
Posted on 2002-05-23 19:02:57 by david


.586
.MMX

.model flat,stdcall
option casemap:none

.code
start:

pxor mm7,mm7
@@: movq mm0,[eax+0]
pminub MM0,[eax+8] <- Error in instruction or register not accepted in current CPU mode
(...)


what's wrong?
:confused:
PS: i try .mmx too.
Posted on 2002-05-24 11:30:13 by coder
pminub is not an standard MMX instruction. It
is supported under .K3D, and .XMM, iirc.
Posted on 2002-05-24 11:37:49 by bitRAKE