Why?
Posted on 2002-06-09 03:49:50 by purefiring
i think u right clicked somewhere in RICHEDIT control and moved the mouse... and then free right click mouse button. That would change some of the 2 fonts size (width and height i guess).


eh eh... now it doesn't work :\ coz of the menu.
i don't remember how i realy did now. :(
i know it was something like what i said.
Posted on 2002-06-09 09:36:52 by coder
To purefiring:

The reason why is because your using a non
english character set, could you tell me what
character set your using.

I thought I had the problem fixed for non english
character sets!!!

You should be able to go to the
Menu>Format>Font And Color Controls dialog and
see if the Courier New font is selected, whether
selected or not press change select Courier New,
Regular, 9 and press ok then press Close and that
should reset your font.

If it does, close AsmEdit and then reopen it again
and see if the font displays ok.

Let me know, I would like to get this problem
fixed, I will work with you to resolve it.

Thanks,

Ewayne
Posted on 2002-06-09 15:01:48 by Ewayne
Hi Ewayne..
as long as we're asking about the look of text etc. here is there a way to set the colors for "just" the text area on the right and have it NOT affect the project and file window? when I change the background of and text background and then set various other color sets for my code, (my backgrounds are both set to black) I end up not being able to see much of anyting in the project/file windows? Am I just missing something?

thanks again
Dave
:stupid:
Posted on 2002-06-09 18:57:54 by dlburlin
Ewayne, I tried your editor and it's working well.
I use the same charset(Chinese Simplified) as purefiring, the same font also. No problem.:alright:
Posted on 2002-06-10 07:32:39 by C.Z.
Hi Ewayne

You get this weird look when you use the richedits zoom function. (Ctrl+mouse wheel). Nothing to worry about, except maybe find a way to disabe it.

KetilO
Posted on 2002-06-10 07:41:23 by KetilO
To KetilO,

Thanks I can sleep now.

Ewayne
Posted on 2002-06-10 08:10:40 by Ewayne
Because even RadAsm has this little "bug" i like to post my solution for this problem here:

.elseif uMsg==WM_MOUSEWHEEL
xor eax, eax
ret

That's what I did in my subclassed RichEdit-Proc. Scrolling works fine but text-resizing doesn't work.
Posted on 2002-06-10 09:01:22 by Rennsemmel
Hi Rennsemmel

This is only true if you have mouse software installed. RadASM has an option (Option / Code Editor / Use Mouse Wheel)
You should uncheck the box if you have mouse software and richedit zooming will be impossible.

KetilO
Posted on 2002-06-10 09:09:19 by KetilO
To Rennsemmel:

Would't this be a better solution.

.elseif wmsg == WM_MOUSEWHEEL && (wparam & MK_CONTROL)

xor eax, eax
ret


Ewayne
Posted on 2002-06-10 09:20:58 by Ewayne
I've Set Font Like That,But..........................
Posted on 2002-06-10 09:43:16 by purefiring
To purefiring:

I wonder why bomb01 is not having the same problem,
because he is using the same character set?

Maybe there is a difference in the way his and
your system is setup.

Try changing the font to the System font and then
change it back to Courier New and see what happens.

Let me know.

Ewayne
Posted on 2002-06-10 10:02:47 by Ewayne
I had that very same problem with AsmEdit myself, and the only way I could fix it was to delete the registry key for the program. It started happening after I pasted some test code off of a web site and in to the editor. I guess it tried to convert something and it just didn't go very well.

As far as RichEdit zoom... if you hold down the control key and use the mouse wheel, you can zoom in and out. Maybe give that a try if deleting the registry keys doesn't help you.
Posted on 2002-06-10 15:15:59 by The Beginner
To The Beginner:

Have you had the problem with AsmEdir V4.3?

You should not have to delete the registry key,
just do a font change and the program should
reset everything.

Thanks,

Ewayne
Posted on 2002-06-10 15:23:48 by Ewayne
Ewayne:

No, this was in v4.2 when I first installed it. But I just tested my mouse wheel theory, and it works.

Open a project, hold down control over the editor window, and scroll your mouse wheel up and down. It eventually looks just like the problem myself and the poster of this thread had.

The registry key deletion DID fix the problem. But you are right, there was no need for it. And changing the font settings didn't help me, as it was the first thing I did to try to correct it.

But scrolling the mouse wheel should help.
Posted on 2002-06-10 15:35:28 by The Beginner
To The Beginner:

The mouse wheel might have been purefiring's
initial problem, but not after he reset the font,
if he did.

With AsmEdit V4.3 you should not have trouble
pasting weird text and with V4.3 you should not
have to clear the registry key to fix a font
problem.

When I post the next AsmEdit update the Ctrl/Mouse Wheel
will be disabled.

Thanks,

Ewayne
Posted on 2002-06-10 15:52:55 by Ewayne
I've tried many many times that change font,reset font,etc.
But Problem exist yet


My OS:Win2000 Pro & Win98 Second Edition
Posted on 2002-06-11 00:05:23 by purefiring
To purefiring:

It looks like the LOGFONT and CHARFORMAT2
characteristics are not matching.

Maybe something in the registry is messed up,
delete the registry key at:

HKEY_CURRENT_USER > AsmEdit V4

Then see what happens, if you are still having
problems I will setup a test program to see
whats going on.

Let me know.

Ewayne
Posted on 2002-06-11 00:50:15 by Ewayne
Problem Yet...........................
Posted on 2002-06-11 08:29:48 by purefiring
Ewayne, I tried your IDE on more than one computers which have win2k installed(char set: Chinese simplfied), and both working properly.

Maybe something messed up in purefiring's Windows?:confused:
Posted on 2002-06-11 08:46:01 by C.Z.