Ewayne,

AsmEdit does not run on my Linux box :(
























:stupid:
Posted on 2002-06-11 08:50:38 by bazik
To bomb01:

Thanks for the reply.

With AsmEdit V4.3 there should not be a problem
when using non english character sets.

I don't know if you have to make any changes to
the system settings if your using a non english
character set.

Did you have to do anything different?

Ewayne
Posted on 2002-06-11 09:05:17 by Ewayne
To bAZiK:

You could borrow one of my window boxs.:)

I would not know where to begin to get it to work
on a Linux box.

Thanks,

Ewayne
Posted on 2002-06-11 09:09:07 by Ewayne
Ewayne, no I did not do any special setup.
Just now I tested it on a newly installed win2k. There wasn't the problem purefiring described.
Posted on 2002-06-11 09:58:18 by C.Z.
To purefiring:

Download the latest FixAsm.zip and FixRes.zip
and update the AsmEdit files.

After you have done that let me know and I will
send you a test AsmEdit.exe to see whats going
on.

Thanks,

Ewayne
Posted on 2002-06-11 10:27:59 by Ewayne
To bomb01:

Thanks for the feedback.

Ewayne
Posted on 2002-06-11 10:29:20 by Ewayne
I've Download fixasm.zip and fixres.zip,but Look the Pic below:
Posted on 2002-06-12 00:45:40 by purefiring
Lot of include files you have there :tongue:
Posted on 2002-06-12 01:03:28 by bazik
Ewayne...
just tried using most recent updates to asmedit and got this result from text that was pasted into a new document tab.



any ideas?
thanks
dave
Posted on 2002-06-12 16:10:37 by dlburlin
To dlburlin:

It looks like when I tried to fix a problem that
may not exist I created a serious problem.

I'll fixit and let you know.

Thanks,

Ewayne
Posted on 2002-06-12 16:43:06 by Ewayne
To purefiring:

The reason why is because It exists double_byte char in your file,The Syntax hi_light of AsmEdit can't calculate char index correctly,DrawText can't display chars in right position,ago,I meet same question yet,I try to fix it for AsmEdit 4.2,here is program and source,try it! if OK ,It is easy to fix for AsmEdit4.3
Posted on 2002-06-12 16:55:37 by ForEver
Hi Ewayne...
Thanks for your last reply... have been using asmedit all afternoon and may have come accross something that might need your attention...

In defining data lables, i used two (2) underscore characters in the name... here's what happened... just a minor nit...



regards
Dave
Posted on 2002-06-12 18:01:49 by dlburlin
To dlburlin and the rest:

Sorry about the problem.

Download the latest FixAsm.zip if you are just
fixing dlburlin's highlight problem above (05:10PM),
just update the AsmEdit.exe and AsmEdit.asm files.

http://asmedit.massmind.org

Let me know if it works or dosn't work.

Thanks,

Ewayne
Posted on 2002-06-12 18:06:14 by Ewayne
To dlburlin:

The double underscore characters in the name will
take me a little time to highlight properly.

Thanks,

Ewayne
Posted on 2002-06-12 18:22:34 by Ewayne
Thanks again for your attention to your users... AND not to worry, as we've all been there before! :alright:

As far as the multiple underlining... certainly isnt affecting me, just thought you'd want to know for the future.
best regards
dave
Posted on 2002-06-12 18:39:03 by dlburlin
To ForEver:

Thanks for helping, let me check out the code.

But why is bomb01 with the same Chinese character
set not having a problem?

Ewayne
Posted on 2002-06-12 18:39:03 by Ewayne
To dlburlin:

Is your paste problem fixed?

Ewayne
Posted on 2002-06-12 18:41:23 by Ewayne
WHOOO HOOOO!!!

Looking Good!!!... tried several different types of files... you've squashed that bug!

regards
dave
:alright:
Posted on 2002-06-12 18:57:31 by dlburlin
To purefiring:

I knew that would not fix your problem, I just
wanted to make sure you and I were using the same
program.

I'm attaching a AsmEditTest.zip:

Unzip AsmEditTest.zip, copy the AsmEditTest.exe
to your AsmEdit directory, open the AsmEditTest.

Open a file and see if the display problem for
your Chinese character is still there

Thanks,

Ewayne
Posted on 2002-06-12 21:49:26 by Ewayne
To bomb01:

Could you do me a favor and see if the above
AsmEditTest.exe still displays the Chinese character
set properly on your system.

Thanks,

Ewayne
Posted on 2002-06-12 21:55:43 by Ewayne