Today strange thing happened which I havent seen before.Compiled code jumps to wrong place or sometimes it omits some codes.I am cluless.Please could you look at my source and tell me what is the error.
RestBackup proc does not work.Sometimes when I call with invoke it jumps to wrong place.I dont know why this error occurs.Thanks.
Posted on 2002-07-19 05:10:26 by LaptoniC
Well i can not ee anything wrong with it besides that you are not showing code that fails ... ie restbackup is never called in example code...

maybe namespce colision for "hwnd" try changing the parameter name to something elese

ie like in

RestBackUp PROC
ARG hwnd1:DWORD
LOCAL ...etc

....
Posted on 2002-07-19 05:55:52 by BogdanOntanu
Click restore button.


.elseif eax == IDM_REST
invoke RestBackup,hwnd

It should call RestBackup proc which is just simple messagebox but when I dissamble compiled exe I see that it doesnt call my proc but some where just above myproc.That is my problem.If you have time please dissamble and you will see what I mean.
Posted on 2002-07-19 07:27:15 by LaptoniC
If you cut & paste the RestBackup proc over the WndProc, it works :)
Dunno whats the problem...
Posted on 2002-07-19 07:42:30 by bazik
if I put 6 nop's to between (less than 6 nop crashes too


...
MakeBackup endp
nop
nop
nop
nop
nop
nop
RestBackup PROC hwnd:DWORD
..

it works and compiles to below strange proc



sub_40167C proc near
hWnd = dword ptr 8

nop
nop
nop
nop
nop
nop
push ebp
mov ebp, esp
push 0 ; uType
push offset aXpresso_0 ; lpCaption
push offset aXpresso_0 ; lpText
push [ebp+hWnd] ; hWnd
call MessageBoxA
leave
retn 4
sub_40167C endp


Now I am clueless.I have tried everything.
So I have removed CTEXT macro and guess what happens everything go back to normal.I dont know why of this but I learned today that never use something that you are not aware of.Hope you gurus can find "why"
Posted on 2002-07-19 08:03:46 by LaptoniC
This problem has been solved HERE by Maelstrom.
Also, see THIS thread for new CTEXT macro. :grin:
Posted on 2002-09-29 15:56:22 by bitRAKE