I am trying to declare a static array of floats. What appears to be happening is the negative values are some how being truncated to 0. Any thoughts?

gpRefCubeVerticesArray REAL4 -1.0R, 1.0R, 0.5R,
-1.0R, -1.0R, 0.5R,
1.0R, 1.0R, 0.5R,
1.0R, -1.0R, 0.5R
Posted on 2001-08-21 18:20:36 by [=CC=]AMBUSH
Afternoon, Ambush.

This won't be very helpful, however I tried replacing
    tmpPWvec31      D3DXVECTOR3     <25.0f, 25.0f,-25.0f>
with:
    tmpPWvec31      REAL4           25.0R, 25.0R, -25.0R
and with:
    tmpPWvec31      REAL4           -25.0R, 25.0R, -25.0R
and with:
    tmpPWvec31      REAL4           25.0R, -25.0R, 25.0R
and it worked fine.

Q: How are use using the array?
Q: Are you looping through it and incrementing the pointer by 'REAL4'?
Q: Are you trying to display the info in the array as text?

Cheers,
Scronty
Posted on 2001-08-21 19:53:17 by Scronty
Scrotny,
All I am doing is trying to get a triangle on the damn screen hehe. But all the negative numbers end up truncated at the origin (0,0). Maybe I just don't get the directx coordinate system. Thought it was X (-1,1) y(-1,1), z (0,1). But if I put thos coordinates in the triangle ends up on the right of the screen (instead of end to end). I am just incrementing by 4 bytes (that is how big a REAL4 is right?)
Posted on 2001-08-21 19:57:07 by [=CC=]AMBUSH
Afternnoon, Ambush.

I've updated the 'matrices' tut (Here) so that it displays a square (with the co-ords you've given).

Cheers,
Scronty
Posted on 2001-08-21 21:57:06 by Scronty