Hi every one,
Try my new VASM version(1.2.0).
It has lots of improvement over version 1.1.0. It has new resource editor and
many bugs were fixed. You can download it from http://www.geocities.com/technosoftt/index.htm .
The dialog editor also produces initialization code. You can disable this if you want to. I think the Auto code creation will be useful for newbies. Please
post your comment's especialy about the resource editor.

Regards,
Pradeepan
Posted on 2002-09-15 14:51:33 by Pradeepan
Hi,
I downloaded and installed Vasm, but got a missing "comct332.ocx"
file when I tried to run it.
I do have the VB6 runtime DLLs installed, so I was puzzled.
Anyway, I found this site:

http://www.angelfire.com/biz/rhaminisys/vboledll.html

which explains everything.
has the ocx file for download and explains how to register it.
.... darn complicated this VB stuff!

note, my system has "comct232.ocx", obviously not good enough!

I'm downloading it right now. Might be a good idea to put a link from
the Vasm download/requirements pages to help anyone else who
experiences problems.
Posted on 2002-09-16 04:00:28 by bkauler
Just did it, placed "comct332.ocx" into c:\windows\system\
then at the dos prompt typed (changed into windows\system first):

regsvr32 comct332.ocx

....and now Vasm starts up!
Posted on 2002-09-16 04:09:48 by bkauler
Errr,
I have to report back again.
Vasm started up ok, but as soon as I clicked on the "File" menu,
it crashed. Gone.
So, I guess that's the end of Vasm for me.
Posted on 2002-09-16 04:58:24 by bkauler
Hi bkauler,
There was a bug. This happens when you close VASM. I fixed it and uploaded the new file. The version number remains the same(1.2.0). I think your problem is that you are using a old version of comctl.ocx. If you want I will upload the full VB Setup program . It will include all the necessary files. Is any one else also having the same problem.

Regards,
Pradeepan.
Posted on 2002-09-16 12:03:00 by Pradeepan
Refuses to work=(
Show a MessageBox(Error in Install paths.Please reinstall VASM.)
What can I do to fix it?
Posted on 2002-09-17 11:02:02 by Duker
Hi,
I just uploaded the full VB setup files. You can download it form http://www.geocities.com/technosoftt/Download.htm . I used RAR
and Winzip because I found it difficult to upload a big file and also geocities refuced to accept files with RAR extension. Therefor it contains
4 parts. Download all 4 files wich are compressed using winzip. Then
run the vasmfull.exe(RAR exe file). It will extract the setup files. Then
run the Setup.exe.
The download seems to be working. I tested it in my
friends computer. If you have any problems post comments here.

Regards,
Pradeepan.
Posted on 2002-09-17 13:33:51 by Pradeepan
1. Resource Editor can not invoke from Project->Resource Editor menu.
2. In Resource Editor, Save button in toolbar doesn't work.
3. If asm unit and resource scripts has the same name, rsrc.rc file and the pointer RC file(which has the same name with .asm file) contains both only a single line of "include ...rc" sentence, thats all. So resource compiling fails.
4. Resource "Form Editing" properties are not enough, since we can not manually edit those hex style numbers.(For example, form sizing menu item from system menu or other form styles)
5. Opening existing resource file is sometimes confusing. Because sometimes,in fact frequently, after invoking resource editor from toolbar, "Vasm Resource Editor" treeview doesn't contains existing form resource. I mean when first created, it is exist but after closed and reopened(res editor) it is disappears.
6. Especially saving resources is takes much time. Like reloading editor(almost).
7. IDE asking to save something frequently without required.

Maybe this 7 complaints because of wrong usage but... Nevertheless, this version is better. Thank you.
Posted on 2002-09-17 20:45:56 by cakmak