i want to read a few menu entries from some program... (the recent files from a cad prog
called unigraphics) okay, i enumerate all windows search for captions that fit to my criteria...
works all perfecly... then i retrieve the menu handle via the GetMenu API... okay, too... but...
when i use GetMenuItemCount or GetMenuString it doesn't work UNTIL i expand the menu or
submenu manually... i mean huh? i tried to put every window to the foreground and sent a few
keyboard messages to it (alt-D/up/up/right/esc/esc/esc) haha that way was more than dumb,
you can see how the menu magically opens up and bla bla bla... half the times it worked, but
that can't be THE solution... how can i activate the menu or could it be that this is only a
program specific behaviour (pleeaase - nooo, this is so damn important for me).

thank you for ANY tips, tricks and workarounds...
Posted on 2002-09-18 11:08:32 by mob
Why dont you read the entries from the registry ? AutoCAD stores them there.
Rename a AutoCAD file to "whereareyou.*" and search for "whereareyou" in the registry to find the reg key :)
Posted on 2002-09-18 11:27:47 by bazik
no no no multiple support must be featured in my interface... registry works only for ONE session
yes yes yes... wm_initmenu and wm_initpopupmenu WORKED... wohoo

thank you anyway... have a nice uhm evening?
Posted on 2002-09-18 11:35:32 by mob

thank you anyway... have a nice uhm evening?


Antarctica - 6 months of sun :grin:
Posted on 2002-09-18 11:50:52 by bazik