i have the following source:
test.asm

.386
.model flat, stdcall
option casemap:none

include c:\masm32\include\kernel32.inc
includelib c:\masm32\lib\kernel32.lib
.data
.code
start:
invoke ExitProcess,0
end start


the problem is when i do ml test.asm i get the error:
LINK: fatal error L1104: \masm32\lib\kernel32.lib : not a valid library
why?
Posted on 2002-09-30 18:06:02 by naidinescu
Try mine. Or you can create your own.

How to create your own MASM import libraries
Posted on 2002-09-30 23:34:58 by Four-F
I just removed the C: from the paths of the include and library file and it build correctly first time. I used the default setup with MASM32.


.386
.model flat, stdcall
option casemap:none

include \masm32\include\kernel32.inc
includelib \masm32\lib\kernel32.lib
.data
.code
start:
invoke ExitProcess,0
end start

Just check if you are using the right linker or alternatively if the path to the library and include file are correct.

Regards,

hutch@movsd.com
Posted on 2002-10-01 02:17:12 by hutch--