Can someone please tell me how I install RadAsm with TASM as the assembly language?



/Henke
Posted on 2002-10-18 20:57:59 by port513
Hi port513

In RadASM.ini you find these lines:


Assembler=masm,fasm,tasm,nasm

Change to:


Assembler=tasm,masm,fasm,nasm

Yo might also need to set the paths with Options / Set Paths

KetilO
Posted on 2002-10-19 01:45:19 by KetilO
Hi

Do I need to install all TASM or just TLINK and TASM32?

And where do I put this files if I have to install everything?

Maybe I have to have a complete installation instruction, step by step on how to get TASM work with RadAsm.

Do I really have use for every file that TASM installs or is it just some files that I can extract and put somewhere?

Where should I put this files? etc etc...


So please a little quick step by step please ;)



/Henrik
Posted on 2002-10-19 02:17:02 by port513
Hi Henrik

You should install all of the TASM to C:\Tasm as you will also need the include and maybe the library files.

KetilO
Posted on 2002-10-19 02:24:15 by KetilO
So you say that it's best to install ALL TASM into some place on the HD?

What's all this folders in RadAsm/Tasm folder? there is an Inc folder etc ...


Maybe I'm stupid but I don't want to install anything that I don't have use for ;)


/Henrik
Posted on 2002-10-19 02:34:33 by port513
Hi Henrik

The RadASM\Tasm folder holds projects and RadASM specific stuff.

From TASM you need tasm32, tlink32 and brcc32 with support files.
You also need all files in INCLUDE and LIB.

I don't use TASM myself so you might need other files from TASM.

KetilO
Posted on 2002-10-19 02:54:52 by KetilO
Hi again

But it's a good idea to install everything then?

When I have installed them in C:\TASM is there anything else I should change in RadAsm?

Can I have RadAsm to put my projects somewhere else than in RadAsm/Tasm ???
I like to keep my programming stuff in one place so I have all my projects in one map Projects/Visual Studio Projects etc


/Henrik
Posted on 2002-10-19 02:59:19 by port513
Hi Henrik

You should now be ready to go.

You can change the projects path by using Options / Set Paths

KetilO
Posted on 2002-10-19 03:16:12 by KetilO
Hi again ;)

Now I have everything installed and it still won't change to Tasm :(

It change nearly everything but Make menu isn't for TASM etc.


How do I make the whoole program work for TASM?

Need a little help here ;)

It looks like it is standard for MASM right? Shouldn't it change to TASM, FASM or whatever you choose as your Assembler?



/Henrik
Posted on 2002-10-19 03:53:18 by port513
Hi Henrik

Did you put tasm first in the list of assemblers?
If so it should work.
Note that if you open a masm project, RadASM will switch to masm.
RadASM will also switch back to tasm if you open a tasm project.

KetilO
Posted on 2002-10-19 04:02:08 by KetilO
Hi

Last question (promisse ;))

Now I get Undefined Symbol: MessageBeep

What files should I include to make that work?

What files should I include in a basic application?



/Henrik
Posted on 2002-10-19 04:48:47 by port513
Hi Henrik

The main reason for me to choose masm was the great job that hutch did and are still doing with the masm32 package.
As far as I know there are noone creating inc and lib files for tasm, so you will have to do prototyping yourself.

I would guess this line should do:

MessageBeep PROCDESC WINAPI :DWORD, :DWORD

In the RadASM package there is included a tasm project. Study it and you will see how it is done.

KetilO
Posted on 2002-10-19 05:15:01 by KetilO
Hi

I think I know where the problem is now.

Import32.lib should be when I compile it but where do I set that? And how?



/Henrik
Posted on 2002-10-19 05:22:50 by port513
Hi Henrik

To repeat myself:

In the RadASM package there is included a tasm project. Study it and you will see how it is done.

KetilO
Posted on 2002-10-19 05:28:11 by KetilO
Hi

Been there, done that

I don't ask if I havent tried


It would be very simple if you could tell me how my tlink32 and tasm32 should look like



/Henrik
Posted on 2002-10-19 05:33:19 by port513
To explain what I tried to do is this


I trid to use this tlink line and it doesn't work here :(


5,OT,$B\tlink32.EXE -x /V4.0 /Tpe /aa /c /L:"$L",3,|,5,||import32.lib||,4


So what is wrong?



/Henrik
Posted on 2002-10-19 05:42:05 by port513
Hi Henrik

If you put these two lines in your code it should work:

include windows.inc
includelib import32.lib

Easy, is'nt it.

KetilO
Posted on 2002-10-19 05:42:40 by KetilO
I still get that error


Can you sen a simple codesnippet so I can check what's wrong here?



/Henrik
Posted on 2002-10-19 05:56:26 by port513
Hi Henrik

Here you go.

KetilO
Posted on 2002-10-19 06:19:17 by KetilO
Hi

Thanks for all the help, now it works ;)

A silly error from me ;)

I'm so used to thoose HLL:s that I didn't really look at my code ;)


Thanks ;)


/Henrik
Posted on 2002-10-19 06:23:53 by port513