I think the videocard (NVIDIA TNT2) is doing some antialiasing on my sprites under certain conditions, turning them into a blurry mess. I knew it did antialiasing whenever I scaled an image but in this case I'm blitting a portion of an image to a rectangle on the destination surface that is the same size. When I use an emulation-only directdraw object the blurriness disappears, hence the conclusion that the hardware acceleration is the culprit.

I don't think the blit function has any flags to control whether antisliasing is performed so I am at a loss as to how to stop this. I don't want to use the emulation-only object becuase it is likely to be slower and its creation fails quite arbitrarily at times. I have DirectX8 but I am using the DirectDraw7 interface. I also downloaded the latest drivers from Nvidia. That doesn't help.

Any ideas?

Thanks.
Posted on 2002-10-20 08:01:38 by Thanatos
Hi,

you can disable anti-aliasing for your nVIDIA card in your control panel under

DISPLAY
-> ADVANCED

There is a control for your card, which offers 3d antialiasing options.

Maybe this can help you.

Greets YaWNS
Posted on 2002-10-20 09:02:29 by YaWNS