Who can tell me?Thanx!:confused:
Posted on 2002-10-26 07:57:52 by jingulong
Hi jingulong

Upload a file containing Chinese characters and I'll see what I can do.

Posted on 2002-10-26 08:58:41 by KetilO
Some chinese characters in TankEdit.inc
I think problem occured in RichEdit's redraw of char-counting.
Hmm,From Windows 95 CHS,It support GBK CODE,
For sample methods,
Just judge ascii value of a byte,if its value upon $80,
this byte and byte+1 would be a "WORD",
in fact, defined from $8100-$FEFF's
"WORD" is a chinese character,two byte.
there no need use UNICODE.
yes If RadASM use GetxxxxW,ether English and chinese or russion character's will be same length:2 byte.
But some old OS like win95,can't support unicode.
Posted on 2002-10-26 21:59:54 by Const.Ex
Hi Const.Ex


Could you try the following.

1. Put a few Chinese characters on the first line in the code editor.
2. Add new lines until Chinese characters goes off screen.

Does the hiliting missalign even if Chinese characters are off screen?

Posted on 2002-10-27 03:36:59 by KetilO
there 5 step.
pic1:I typed a chinese character on firstline,and a invoke on second line.
pic2:While radASM refresh(RichEdit Redraw),highlighting misalign.
Pic3,Pic4:I try to select to resume align.
pic5:highlighting be the same as pic1.

and then when radasm lost and get foucus,
it looks like pic2 back.
Posted on 2002-10-27 04:18:38 by Const.Ex
Hi Const.Ex

My theory was right.

Try this RadASM version.


You must check Option / Code Editor / Chinese Strings.
You must also set Comment and String color to same as Fore Color.


There was a bug. Try this one.

10/29/2002 Deleted zip. uploaded to my web site.
Posted on 2002-10-27 04:32:11 by KetilO
under Windows XP use this 1215,checked that Option and changed the Strings/Comment's color to foreground.

I think in win98 and 95 will be same results.
It's PM 10:07 now...
I must go to sleeping
Posted on 2002-10-27 08:03:30 by Const.Ex
Hi Const.Ex

There was a bug. I hav uploaded a new zip.

Posted on 2002-10-27 10:54:05 by KetilO
thanks for your work.
If I guessed,
I think you disabled comment and strings highlighting when choose that option to fixed this bug.
Hmm,Disable strings highligting is enough,sure,it's fit to me,because I never contain chinese character in comment.
If I use chinese character in strings I always place them in .inc file and edit it with other editor like UE32.
I know some other chinese newbie always add lots of comment in their code,:),so disable comments highting were good feather for them.

thanks again.
BTW,Some times new chinese programer,contain me,possible post some poor english in the message,
we regret for it.
Posted on 2002-10-27 18:17:49 by Const.Ex
Never worry about your english here. If people come across a phrase they can not understand I am sure they will ask a question about it. I am just ashamed that the people in my country can not speak more then their own native language.

Have good days,
Posted on 2002-10-27 18:40:47 by Betrayed
that's right.
Some arab people chart to me in MSN Messanger,
they always use arabic first,sure I can't read arabic language,
and they only can use some short english Sentence like "I love you","what's you naime","bye!"
so we send smile-face to chart....
like :) :( :o :grin: ;) :tongue:
Posted on 2002-10-27 18:55:10 by Const.Ex

I have an idea about how to draw chinese chars so I will try to make it possible to enable hiliting on comments and strings.

Posted on 2002-10-28 00:47:32 by KetilO
:grin: !
Posted on 2002-10-28 01:14:10 by Const.Ex
Hi Const.Ex

My 1000'th post. :alright:

You should now be able to use colors on comments and strings.
Will probably only work on NT platforms tho.

Posted on 2002-10-28 02:25:44 by KetilO
under 98,all chinese characters display as two Rectangle.
highlighting work fine.
under XP,when set comment color different to fore-ground there some rectangle and some strange sign,
and will mis align.
comment highting works fine when set color to fore-ground,
strings highliting is as same as comment.

I think it is such enough to me....
I can set strings color to gray for chinese charater,
when set yellow to comment--I've never use chinese word in it...
Posted on 2002-10-28 03:38:20 by Const.Ex
Hi Const.Ex

Well, it was worth a try.

Posted on 2002-10-28 04:59:11 by KetilO
Can not support chinese... when i input chinese, the IDE Crash!!!!
Posted on 2002-10-30 05:01:50 by free2000fly
Hi free2000fly

1. Download RadASM from my web site.
2. On Option / Code Editor check Chinese strings
3. On Option / Editor Color set Comments and Strings color to same color as Fore color.

If you do this it should work.

Posted on 2002-10-30 05:50:13 by KetilO

I tried to install chinese on my computer to test it. It does not appear to be stable yet.
I will have to test some more.

Posted on 2002-10-30 06:37:30 by KetilO
Hi KetilO.

Can you please open this file with RadASM & Ultra Edit 32, see what is the different

When you press Ctrl-Home & Ctrl-End, RadASM crash.

Posted on 2002-10-30 09:07:24 by QS_Ong