Hi all,

and please help who understand TASM!

problem:
When I call OleUnInitialize, tlink32 says "Unresolved External Symbol". How can I solve this?

I tried;

1. extrn OleUnInitialize :PROC <- in asm module
2. OleUnInitialize PROCDESC <- in include file
3. Searched in net
4. First with coff2omf utility converted masm32's ole32.lib to tasm ole32.lib(for my surprise without error) and linked together import32.lib
5. Ask to others (what I'm doing here)

...another say, generally how can I use OLE32.DLL and others which doesn't place in "import32.lib" ?

thanks for whoose suggest for solving my problem.

Regards
Posted on 2002-12-02 03:40:15 by cakmak
did you try to do a lib directly from TASM
implib -c -f ole32.lib ....ole32.dll
impdef -h ole32.def ---ole32.dll

'cause def file seems to be correct for you OleUninitialize
then just put the extern in asm
and compile and link it with also ole32.lib
there is no prob for me
Posted on 2002-12-02 08:10:20 by Thor0Asgard
No, I didn't tried it. But will try. Big thanks for help.

Regards
Posted on 2002-12-02 10:19:49 by cakmak
When the error "Unresolved External Symbol", it means that you never include the correct .lib file.

Hope it helps :grin:
Posted on 2002-12-02 10:46:34 by roticv