I am trying to create a very simple test project in RadASM. I only want it to contain 1 single asm-file, which brings up a hello world messagebox.

I choose "new project", masm, win32 app, file creation: only asm, and the rest defaults.

I then enter this very simple program into the single asm-file in the project:

.model flat, stdcall
option casemap :none ; case sensitive

include \masm32\include\windows.inc
include \masm32\include\user32.inc
include \masm32\include\kernel32.inc

includelib \masm32\lib\user32.lib
includelib \masm32\lib\kernel32.lib

; ##############################


str1 db "Test1", 0
str2 db "Test2", 0
invoke MessageBox, 0, offset str1, offset str2, MB_OK
invoke ExitProcess,0
end start

It can compile without a problem, but when I try to build it, I always get the following error message:

LINK : fatal error LNK1181: cannot open input file "Test Proj.res"

Where is this file referenced, and how do I remove this reference? I don't have any resources in the program, and I don't want to have it either. Isn't it a bug that this file is referenced even though it is not created when the project was created (I said in the project wizard that I didn't want any res-files created)?

I have tried to read and edit the project ini-file, but with no luck. :(

Any help or tips would be really great.

Posted on 2002-12-06 10:56:27 by dELTA
Ok, I found it. It was the "4" at the end of the link command specification string.

I'm not sure, but maybe it would be better if this "4" would be removed if the rc files have been deselected in the project wizard? After all, people who use such wizards (like noobie-me :)) might not understand how to decode those strings so easily. :)
Posted on 2002-12-06 11:16:17 by dELTA
I'm new to RadASM.

But, I got the same error because I had the boxes checked for the Res folder and Rc file in the File and Folder Creation wizard when I created a new project. It automatically puts those commands in the Res to Obj build line.

Just recreate your project, but don't take the defaults.
Posted on 2002-12-06 11:20:31 by Kdr Kane
You may check out Help folder and also RadAsm.ini first.
Posted on 2002-12-07 22:57:36 by cakmak