Hi all

Here is a test of RadASM 2.0 with RAEdit code edit control.
It most likely still has bugs. Help me find them.


12/26/2002 16 dl. Fixed expand/collapse problem. Fixed use hilite not working. Made file opening less jumpy.
12/27/2002 32 dl. Fixed dbl click on error in output. Added linenumber font/color. Hide the caret when there is a selection.
12/28/2002 56 dl. Fixed vkim's debug macros problem. Added bookmark/breakpoint painting.
12/29/2002 28 dl. Fixed exit problem. Fixed tab width option not working.
12/30/2002 70 dl. Added line-number options. Added Tab/Shift+Tab to indent/outdent block. Added Control+Left/Right to move to start/end of word. Addet Control+W to close mdi child. Fixed a bug in output window not showing selection. Fixed a print bug not color hiliting words.
1/1/2003 70 dl. Fixed a fasm project bug (code write macro). Code write macro now expand tabs if option set. Fixed Tab-key block indent. Fixed a bug in RAEdit that could cause GPF.
1/2/2003 47 dl. Fixed slow Select All. Fixed slow caretmovement on proc line. Fixed bookmark paint bug.
1/3/2003 68 dl. Fixed several minor bugs. Fixed prototype bug.
1/4/2003 31 dl. Fixed misplaced api listbox/tooltip if there is a split window.
1/5/2003 49 dl. Fixed tool window move bug. Added state indicator (Changed=green, Readonly=red). Added Shift+Insert to paste.
1/6/2003 30 dl. Speeded up block indent/comment. Tried to fix a paste problem on NT/2k
1/6/2003 20 dl. Another try to fix paste problem on NT/2k
1/8/2003 60 dl. Made the release with minor adjustments. Thank you all for your help.
Posted on 2002-12-26 09:47:03 by KetilO
Hi KetilO,

I only wanted to look. And while closing crashed. Then tried again, unfortunatly the same thing every time(win98). Crashing while close.

Posted on 2002-12-26 10:18:06 by cakmak
no problems until now ... seems to work fine for me ... i'll delete the old one :grin:
Posted on 2002-12-26 10:20:45 by MerlinDMC
With the richedit control, I could hold down the scrollwheel (like a third mouse button) and then scroll the text by dragging the mouse up or down. This doesn't seem to work with your control, but this may be an error in the mouse driver and not in your code.

No other complaints, great work :)
Posted on 2002-12-26 11:47:42 by Qweerdy
It works in Win2000 Pro Sp3.

However i have one question. Where does the option for displaying line number is??

Also there is a bug. I think it is related to the RadASM code editor compoent. When i delete a double-byte character, only one byte is deleted such that two delete keys should be pressed.

The code folding feature is very great and what i expected to be a professional editor. Good work!!
There is one bug needed to be solved: When there is two or more procedures in a assembly file, continuously keeping the folding, unfolding, folding, unfolding.... the procedure, the insertion point moves to somewhere and the scrollbar scrolls. It sometimes happens, but not frequent.

Will the code folding feature will be implemented for dealing with macro also?
Posted on 2002-12-26 11:54:32 by yoursguideline
Hi all

Thanks for your help.

I have fixed some of the bugs and will fix the others with time.

Posted on 2002-12-26 15:31:32 by KetilO
Some UI stuff:

Is there a way to set the line number color?
Also it seems that the line number font is same as the code editor font, is there a way to set them different?


A bug (i think):
-- precondition: a file longer than a height of the code editor
Ensure the scrollbar thumb is not at the end. HOLDING down the scrollbar thumb and drag it down until the scrollbar thumb is at the end. STILL HOLDING down and not release the mouse press. A tooltip displays the line number. It is normal. But if still move your mouse down until the mouse pointer is outside of the RadASM window/code editor window, the scrollbar thumb restore its position automatically where you start to drag it. The tooltip does not at the side of the scrollbar thumb.
Posted on 2002-12-26 16:50:06 by yoursguideline
Hi yoursguideline


Line number font/color added.

The scroll tip follows the mouse in y direction, so this 'strange' behaviour is expected.

Posted on 2002-12-27 06:16:50 by KetilO
I am downloading,so glad to see a new release(I missing RadASM from
Felling tiered....
many days for PHP and ASP coding.....
And forgot many friends here.
Posted on 2002-12-27 08:26:07 by Const.Ex
It doesn't display line numbers above 999 very well. :grin:
Could you perhaps adjust the width of the line number strip to the number of lines in the file?

Oh, and one more thing: when I nest a structure like so:

MySmallStruct struct
w dd ?
h dd ?
MySmallStruct ends

MyStruct struct
foo dd ?
MySmallStruct <>
MyStruct ends

The popup list for MyStruct contains foo and MySmallStruct, while it should contain foo, w, and h.
Posted on 2002-12-27 09:26:02 by Qweerdy
Cute Code tree,none miss align in highlilighting.....
comfortable to try it....
Posted on 2002-12-27 20:58:58 by Const.Ex

I tried VKDEBUG v1.1 with RadASM 2.0c but the output strings appear on 1 line
Posted on 2002-12-28 01:14:18 by X05
When I exit I get allways below error

RADASM caused an invalid page fault in
module RAEDIT.DLL at 0167:10005ac2.
EAX=0050b440 CS=0167 EIP=10005ac2 EFLGS=00010202
EBX=0050b440 SS=016f ESP=006bebb4 EBP=006bec54
ECX=de3670a0 DS=016f ESI=00008cfa FS=47e7
EDX=0001dce4 ES=016f EDI=006bec8c GS=5b6f
Bytes at CS:EIP:
8b 83 fc 00 00 00 3b 43 10 75 05 8d 73 10 eb 03
Stack dump:
006bec8c 00008cfa 006becd6 00000000 00000000 25a80082 5c200003 043017a7 36978c08 000116f7 00000000 00000000 0bd80082 17a75c20 00820bd8 00000000

I have win98 se
Posted on 2002-12-28 05:04:05 by LaptoniC
arghh... my mouse wheel (logitech) does not works in RadAsm :( for longer code snippets a mess...
anyway, very good work !
Posted on 2002-12-28 06:39:55 by Zero
Hi Zero

Try to check Options / Code Editor Options / Use Mouse Wheel
Leave this unchecked if you have mouse software installed.

Posted on 2002-12-28 07:55:02 by KetilO
Hi all

New upload:
- Fixed vkim's debug macros problem
- Added bookmark/breakpoint painting

Thank you all for your bug reports and suggestions. I will handle them with time.

LaptoniC and others having problems with Win98 SE:
Does it happend when exiting RadASM or when closing a window? Are your system having little ram (<128k)?
I have Win98 SE myself and does not have this problem.

Posted on 2002-12-28 08:06:54 by KetilO
Will the multiline comments syntax highlighting be supported? I am looking forward for that.
We can close a MDI window by Ctrl+F4 in RadASM, how about Ctrl+W? Mostly windows application supports Ctrl+W to close a MDI window.

Qweerdy:It doesn't display line numbers above 999 very well

Yes, i found that the line number column is fixed. We need to change a smaller font to fix in. The ultimate solution is to have a dynamic width feature in it. :)
Posted on 2002-12-28 09:15:10 by yoursguideline
I have 256 MB ram hopefully bigger than 128 K :grin: This happens when I exit RadASM.When I open/close files within radasm it doesnt give any error.However when I exit whether any file is opned or closed it gives error.
Posted on 2002-12-28 14:05:32 by LaptoniC
Hi LaptoniC

Yea, still living in the 8bit days, counting memory in Kb. :grin:

Your problem might be an old or corrupted RadASM.ini file.

Try replacing section with this:

;Visible, (TRUE/FALSE)
;Docked, (TRUE/FALSE)
;Pos, (Left=1,Top=2,Right=3,Bottom=4)
;FloatingRECT (Left,Top,Width,Height)
;The last tool will be clipped by all others
;1=Project, 2=Output, 3=ToolBox, 4=Property, 5=TabTool

Posted on 2002-12-28 14:55:17 by KetilO
didnt chnaged anything I debugged and saw the error.Here is the lines that cause error.I guess ,your wndproc which start like this

invoke GetWindowLongA,hWnd,0
mov ebx,eax
.if eax
loc_10005AC2: ;error line
mov eax, [ebx+0FCh] ; Here is the error.When I look with debugger I see ?? in this region.
Posted on 2002-12-28 16:21:01 by LaptoniC