Hi LaptoniC

Thanks, that makes sense.

Try this version of RAEdit.dll

KetilO

Edit:
Deleted attachment.
Posted on 2002-12-28 16:54:18 by KetilO
Heya Ketil

For me it fixed the problem :) really great work :)

Will you implent variable tab? I mean I usually use 2 spaces for tab so now my code is miss align its my only complain :)

Cya greetz Kahn
Posted on 2002-12-28 17:03:08 by KahnAbyss
Hi KahnAbyss

Thanks,

Yes I will fix the tab size option.

KetilO
Posted on 2002-12-28 17:17:07 by KetilO
Hi Ketilo, as always you dazzle me with the quality of your work

Just tried your version 2 of RadAsm. One thing I think you should do is concerning one of the plugin modules. When the function gets retracted into a plus sign region. The final endp remains when the region is collapsed. I think you should remove it from the display and also maybe highlight the collapsed region differently to make it stand out more

otherwise, great work - the syntax highlighting flickering while scrolling seems to be gone. Great improvement
Posted on 2002-12-28 21:31:50 by compucoder
Hi all, first time.

I got your version 1.2.1.9, yesterday before discovering that the new one released so I downloaded it too.
I must said that your editor is very nice, what help me like to study MASM hard. The old one work fine, I tried to look for "What is new" like others software but failed so I opened 2.0 to cmp..failed too :-). I decided to take part in this forum for more interesting thing. Just time when closing V2.0 to connect I got erros messages. " Cause...in radedit.dll",...I tested several time while registering as a member here. But it is still in the same condition. Is that a tiny bug :-)). I will check it later. I use Window Me. I find 1.2.1.9 too good for me...

Thank you for your greatest editor. Now trying to Cry Out " ASM is Great and Simple". Search forum now

:alright:
Posted on 2002-12-28 22:49:21 by Halong
Hi compucoder

Thanks for your suggestion. I will have to see how that match with future plans.

KetilO
Posted on 2002-12-29 05:24:36 by KetilO
Hi Halong

Thanks,
Welcome to the board.
Version 2.0 is not released yet, still testing.

KetilO
Posted on 2002-12-29 05:27:02 by KetilO
How stupid I am to inform you that :-)

Well your editor is very cool. I spent all last night to play with it without learn nothing about Asm. It help me a lot with 'debug' code in asm source ;-)( I am lazy in reading tutorial of others, just like reading code to study untill do not understand something). Sooner or later I wil know your homepage, but Just think so I ask. Where is it my uncle ? :-), to collection more wonderful codes.

Is it stupid way to study ASM. I have so many code that spend more time on testing it than on writing my own codes. The more I test the more I like to learn asm. :---). Small and fast...Great.

Happy new year to all. In my country It will be in about 2 months.
Posted on 2002-12-29 19:51:45 by Halong
Thanks,

My problem solved after RadAsm20e too, which I post first.
Posted on 2002-12-30 08:00:59 by cakmak
Something else I found out

when you use Ctrl-Arrow to move cursor it only move 1 space instead jumping to next word

Cya greetz KahnAbyss
Posted on 2002-12-30 10:38:10 by KahnAbyss
Hi all, and thanks for your bug reports / suggestions.

New upload at the top of this thread.

Whats new:
- Added line-number options.
- Added Tab/Shift+Tab to indent/outdent block.
- Added Control+Left/Right to move to start/end of word.
- Addet Control+W to close mdi child.
- Fixed a bug in output window not showing selection.
- Fixed a print bug not color hiliting words.

A happy new year to you all.

KetilO
Posted on 2002-12-30 15:05:55 by KetilO
Ive found a bug...

If you collapse a function and indent it with Tab or F9 then outdent it
it expand the function and the little "+" is still here and put "-" on the line over

cya greetz Kahn
Posted on 2002-12-30 15:34:13 by KahnAbyss
Hi Ketilo,

I'm sorry for my bumping error reporting. :(
But the error on Win98SE with Fasm was still exist ( not affected with 2k XP,ME dunno ) with current version ( 2.0f ).

How to reproduce an error is create a Fasm project and enter any text then press enter.

RADASM caused an invalid page fault in
module RADASM.EXE at 0187:0040912c.
Registers:
EAX=00000066 CS=0187 EIP=0040912c EFLGS=00000206
EBX=006bfcfc SS=018f ESP=006bf914 EBP=006bf924
ECX=00000001 DS=018f ESI=73004540 FS=1177
EDX=00451c17 ES=018f EDI=00451c16 GS=0000

Bytes at CS:EIP:
8a 26 0a e4 74 29 0a c0 74 25 0a ed 75 17 3c 61

Stack dump:
006b0000 00008d3c 73004540 0000000d 006bfc50 00410e41 00451c16 73004540 00000000 00000001 73004540 00000014 00453c22 6d726f66 00007461 00000002
Posted on 2002-12-31 03:40:34 by Bi_Dark
hi.. RAEdit 2F control just crashed on me.. (1st time!)

The cursor was at end of line and I pressed enter on numpad. Last character on line was )
(also sure I saw movewindow call with no handle and/or negative numbers..)

ESI = 0B993D28
EAX = 0000947D
ECX = 00000020

10003DA2 FFB3 FC000000 PUSH DWORD PTR DS:
10003DA8 C783 FC000000 00>MOV DWORD PTR DS:,0
10003DB2 3B16 CMP EDX,DWORD PTR DS: <=== access violation here
10003DB4 73 53 JNB SHORT RAEdit.10003E09
10003DB6 0FB64432 10 MOVZX EAX,BYTE PTR DS:

contents of were 0

thanks :)
Posted on 2002-12-31 19:47:11 by X05
DialogAsMain Template of RadASM 2.0F was tested by newbie under Win2K

Pro.

Bug

- When you open a project, you cannot edit (double click) the .dlg file

directly. However, it's working only if the .rap file opened (double

clicked) firstly.

- If the "Dialog coder writer" dialog box (Tools/Dialog to window)

opened and a menu file is linked with, then this menu file cannot be

deleted as long as the project file is being deleted which will affect

the Output window.

Suggestion

- Add a HOTKEY to Tools/Dialog to window.

- Remove "ID equ's" from "Dialog coder writer" since it can be easily

done by Tools/Export ID equ's (Ctrl+F11).

Question

- I do not see any benefit of all the items except "Commands" in Export

combo box. Could you give me any hint?

I like RadASM so much, it is an artwork!

Wishing KetilO and all of you here have a very happy new year!

ty from P.R.China
Posted on 2002-12-31 22:46:10 by ty123
also there is something wrong with END key on end of line. + backspace from next line.

RadASM 2F: tab size4: convert tab to spaces, auto indent

example: (spaced ident, of 4 chars)

.if ( eax )
.else
mov eax, b<=== put cursor after the b
.endif

; here are keys to repeat. there are no spaces after the b
; END <= no cursor movment. good
; ENTER 3 times
; HOME CURSOR
; UP CURSOR
; UP CURSOR
; BACKSPACE
; END <= where did those 4 spaces + 1 tab come from?
; BACKSPACE 5 times
; ENTER
; HOME
; BACKSPACE
; END <= they are back!


well I never it happens in 1.2.1.9 to!

thanks :)
Posted on 2003-01-01 03:14:57 by X05
Hi all

Thanks for your bug reports / suggestions.

New upload.

Whats new:
- Fixed a fasm project bug (code write macro would cause GPF).
- Code write macro now expand tabs if option set.
- Fixed Tab-key block indent. The whole line must now be selected.
- Fixed a bug in RAEdit that could cause GPF.
- Fixed a text edit bug that caused Ctrl+V not to work.

KetilO
Posted on 2003-01-01 07:32:45 by KetilO
Hi X05

The example is normal behaviour of most edit controls with autoindent (except tab char which came from code write macro not expanding tabs).

KetilO
Posted on 2003-01-01 07:47:22 by KetilO
Hi donkey

No it is RadASM20g.
Probably some proxy chash problem. Try again later.

KetilO
Posted on 2003-01-01 08:35:38 by KetilO
Hi KetiIO,

Select All too slow.
One GB file takes over 90 seconds: OS Win98 SE, Micro 450 Hz.
Radasm 1.2.1.9 takes only 2 seconds per GB.

ipadilla
Posted on 2003-01-01 11:35:46 by ipadilla