Hi,
It's after 7am, and after coding all night in DirectX i've decided i'd like to learn some MASM32.

I've booted up QEDITOR and typed in a simple program. To compile it i assume i go to the Project menu and select BuildAll.

Cmd.exe comes up and says:

Assembling: c:\documents.asm
MASM : fatal error A1000: cannot open file : c:\documents.asm

Damn right u can't open it, cuz it's not there. I thought this MASM32 package was suppose to contain everything i need to get up and running.

Am i missing a setup procedure? or does the compilation process involve more steps...

Thx in advance for any feedback, much appreciated. I think i'll go catch some Zzz's now, my brain is numb.
- pho.
Posted on 2002-06-03 09:11:43 by pho
Is this the name of your asm file?
or is it a file that is included by your asm file?
Posted on 2002-06-03 09:25:23 by Kudos
Well,

I use the ProStart Wizard to setup a project, then I delete the code, type in some new stuff, and try to BuildAll. That's when I get the above error.

How would I go about building a project from scratch?

- pho
Posted on 2002-06-03 09:31:14 by pho
hi pho

Pressing build all in qEditor builds the currently loaded .asm file into an exe. So just open an asm file and hit build all.
Posted on 2002-06-03 09:43:47 by Kudos
If I load up any assembly and try BuildAll I get the error in the first post.

It's something to do with MASM, perhaps I don't have all the appropriate files.

- pho.
Posted on 2002-06-03 10:19:47 by pho
I assume you have the masm32 package from hutch's website. That contains all the files you need to compile. Maybe you could try building one of the example asm files that come with masm32.
Posted on 2002-06-03 10:25:41 by Kudos
ok,
so i open up qeditor and go the Template menu and select Blank Template.

Then, shouldn't I go to Project->BuildAll to compile it?

-pho.
Posted on 2002-06-03 10:27:36 by pho
Building the examples works fine.
Posted on 2002-06-03 10:29:17 by pho
hmm
if the example works fine then I'm not sure why your code dosen't build. I just go to file ->open and open up my asm file and hit build all and everything works fine.
Posted on 2002-06-03 10:34:56 by Kudos
So, u can Build a blank template no problem?
Posted on 2002-06-03 10:40:15 by pho
Assembling: c:\documents.asm
MASM : fatal error A1000: cannot open file : c:\documents.asm


When using QEDITOR this could happen if you have a file named documents with either no extension or an extension that isn't .asm then it would try to compile doucuments.asm wich wouldn't exist
Posted on 2002-06-03 10:41:22 by Kudos
Do u have a documents.asm in your c drive?

There is no documents.asm anywhere on my drive.
Posted on 2002-06-03 10:44:44 by pho
nope
I thought that was the name of your asm file since thats what it said it was assembling.

You can attach your assembly file to this board and I'll see if it will compile for me if you want.
Posted on 2002-06-03 10:47:20 by Kudos
aha, i created a project in a folder on my desktop (c drive) then moved it to the masm folder.

i get a different error

Assembling: c:\masm32\new.asm
MASM: fatal error A1000: cannot open file: c:\masm32\new.asm
Posted on 2002-06-03 10:52:03 by pho
Woot!

Moved the files out of the folder (now all project files are in the masm directory) and it compiled successfully!

Obviously something with paths. Maybe a batch file fixes this?

- thx for all your replies Kudos, much appreciated.
-pho.
Posted on 2002-06-03 10:54:32 by pho
hmm
so your asm file is named new.asm and it's in the masm32 folder?

EDIT
Cool I posted this before your last post. It seams strange that putting it in a folder means it won't compile I have all my projects in seperate folders and it works fine.
Posted on 2002-06-03 10:55:43 by Kudos
its because qeditor isnt recognizing spaces in windows 2000/XP. this can be fixed by opening qeditor clicking tools-->change editor settings. in the lower pane of the window that pops up you need to put quotes around all the {b} like this:

"{b}"

it should work fine now.
Posted on 2002-06-03 11:14:08 by smurf
Thx Smurf,

Now i can finally sleep. That was really really really frustrating.

- pho (relieved).
Posted on 2002-06-03 11:32:43 by pho